Difference between revisions of "ALSA"

From HaskellWiki
Jump to: navigation, search
 
Line 19: Line 19:
 
>=1.0.14 is required but it could not be found.
 
>=1.0.14 is required but it could not be found.
   
then you need to install the alsa development packages. On Debian or Ubuntu, do `sudo apt install libasound2-dev`.
+
then you need to install the alsa development packages. On Debian or Ubuntu, do
  +
  +
sudo apt install libasound2-dev
   
 
[[Category:Music]]
 
[[Category:Music]]

Latest revision as of 08:05, 18 March 2019

The Advanced Linux Sound Architecture is addressed by currently three different projects.

Related packages are

  • midi-alsa: Conversion between data types of the alsa package and the midi package


Troubleshooting

If you get a message like

   Configuring alsa-core-0.5.0.1...
   Cabal-simple_mPHDZzAJ_2.2.0.1_ghc-8.4.3: The pkg-config package 'alsa' version
   >=1.0.14 is required but it could not be found.

then you need to install the alsa development packages. On Debian or Ubuntu, do

   sudo apt install libasound2-dev