Pairs of identifiers
Frequently functions appear in pairs like
show and so on.
Libraries are a lot easier to use if they use a consistent scheme of names for related functions.
It is even better if many libraries would share the same scheme.
This can be useful both for designing function names and
for easy guessing of the counterpart of some function.
Here is a collection of some pairs of identifiers I stumbled on in AmigaOS, MUI, Modula-3, Haskell libraries, and C++ STL. This could be a basis for further discussion.
It would be great if the discussion lead to a more streamlined collection where for instance some duplicates are removed.
read and show
I think the names
show in the Prelude of Haskell98 aren't a good choice
because the functions can be considered as natural pair
but this isn't reflected by their names.
show sound like some I/O operations which they are not.
The choice for the Modula-3 libraries (
Fmt) seems to be more suitable. -- HenningThielemann
I had a nice discussion the other day with someone about the right name for tree nodes and leaves. The constructors I'm using as a result are
Leaf. Anyone feel differently? -- BartMassey
I think 'del' is more natural pair for 'add'. --Evgeny Tarasov