Talk:The Other Prelude
i have no idea what i'm talking about here, but shouldn't "Monad m" imply "Functor m" if we're already starting with a clean slate? Also, what should the solution to "head", etc be? --Johannes Ahlmann 09:47, 21 December 2006 (UTC)
- "Monad m" should imply "Functor m". By your question about "head", do you mean the problem of it being undefined on
? BrettGiles 14:13, 21 December 2006 (UTC)
fstet cetera are projection functions. They can, in fact, be achieved by pattern matching, and are done that way often. It seems to me that at least the Prelude should be very mathematical and leave them out. YMMV. But
Monad mshould really imply
Functor mif we want to be mathematical, and indeed we do. --Pirated Dreams 22:33, 21 December 2006 (UTC)
- I'm not so sure whether you can just leave projections out of the prelude and it definitely wouldn't solve the underlying problem. Also I'd love to see some functions from MissingH (especially a sensible "split") in the prelude. Furthermore there's the question which functions from other libraries should be exported by Prelude (either, list functions, error/catch, fail, fmap, IO functions, mapM, maybe, read/reads, sequence, Numeric functions, ...). There definitely has to be some discussion about the necessity of including some of these. --Johannes Ahlmann 12:34, 23 December 2006 (UTC)
Although the name of the page "The Other Prelude" does not seem to fit the Wiki standard (sentence case says: The other prelude), I left it as it appears to be a proper name when you read the content. BrettGiles 14:13, 21 December 2006 (UTC)
- Yes Brett, at least that was my intention. --Pirated Dreams 22:33, 21 December 2006 (UTC)
I propose the following:
- The Functor hierarchy proposal should be adopted.
- There will be basic algebra modules in the Prelude hierarchy. Named, possibly,
TheOtherPrelude.Algebra, if the numerical prelude people are happy with it. At this point I think the name, though clear, is very long.
- I propose operators to be preferred over alphanumeric names.
(++)seems way cooler than
M.plus. YMMV. Vote here. About the precedence issue, I think proper usage of parentheses is enough for all practical purposes. Besides, (++) is associative.
joinis the same as more specific
concatas far as I get it. The task it accomplishes is more accurately described by the English word "join" than pseudoEnglish "concat". I think there should be no "concat" at all. One of the principle goals of this project is reducing the API.
- This is basically a question... (>>=) is equivalent to
concatMapin the list monad. I am not exactly a fan of the name, the Scala community uses
flatMapas far as I recall. Should we include the function
flatMapin the monad? Has one advantage, sometimes it's intuitive. I reckon it's intuitive whenever (=<<) is.
--Pirated Dreams 12:38, 28 December 2006 (UTC)
- If we really want to go for consistency, then perhaps 'joinMap'? Nmessenger 00:05, 4 January 2007 (UTC)
joinMapis consistent in that is says what it does :)
flatMapwould have introduced it (
join . map) as a bit more sophisticated concept (highlighting the map underneath the monadic container). Doesn't really matter. Thanks for pulling
(>>)up. I am not aware of any caveats, though the experts may jump in and say "you see, this and that are the reasons we didn't do it ..." and ruin the day ;)
--Pirated Dreams 11:02, 4 January 2007 (UTC)
I found out that we have been duplicating Gofer's prelude here :p
Also, projecting the future, I see we'll be seeing duplicate definitions in the prelude (like
(.)). I think we can do something here. Mostly, this renaming is worthwhile for one reason: sometimes they are useful as operators, sometimes as functions. I think we should keep one of them inside the class, the other outside. This guarantees that they mean exactly the same thing. This provides cleaner documentation and consistency. If someone wants to provide an alternative defintion of
(.) (say) s/he can hide it from the prelude.
--Pirated Dreams 11:11, 4 January 2007 (UTC)