Difference between revisions of "Arch Linux/6.12 Upgrade"

From HaskellWiki
Jump to: navigation, search
Line 32: Line 32:
   
 
Once cabal2arch has the new provides list, then new PKGBUILDs need to be generated with those new dependencies listed.
 
Once cabal2arch has the new provides list, then new PKGBUILDs need to be generated with those new dependencies listed.
  +
  +
== The ./gen-index script ==
  +
  +
The haddock index generation script used in all install hooks for Haskell libraries is in a different place for 6.12. We need to update the GHC package to fix this.
   
 
== General breakages ==
 
== General breakages ==

Revision as of 23:56, 18 January 2010

When GHC 6.12 comes out, several things will have to change in the Arch binary repositories, and in most Haskell PKGBUILDs.

The following are required to be dealt with.

Smaller core set

Arch supports the Haskell Platform spec in binary form. GHC 6.12 comes with a smaller set of libraries built in than 6.10.4 did, so for those that are no longer shipped with ghc, we need to create binary packages in [extra]. That is, for (those in italics are already moved):

Update "provides" list for GHC

With these new libraries removed from the default set, two things must be updated:

  • The GHC package 'provides' list. It provides all the things listed here
  • The cabal2arch provides list to match.

Update cabal2arch

Once cabal2arch has the new provides list, then new PKGBUILDs need to be generated with those new dependencies listed.

The ./gen-index script

The haddock index generation script used in all install hooks for Haskell libraries is in a different place for 6.12. We need to update the GHC package to fix this.

General breakages

Other packages may in general be broken by GHC changes (not Arch-specific things). Those are updated as notcied.