Personal tools

Arch Linux/6.12 Upgrade

From HaskellWiki

< Arch Linux(Difference between revisions)
Jump to: navigation, search
(Removing this page, completely outdated.)
 
Line 1: Line 1:
When GHC 6.12 comes out, several things will have to change in the Arch binary repositories, and in most Haskell PKGBUILDs.
+
This article has been removed, all information in it was outdated.
 
+
The following are required to be dealt with.
+
 
+
== Smaller core set ==
+
 
+
Arch supports [http://code.haskell.org/haskell-platform/haskell-platform.cabal the Haskell Platform spec] in binary form. GHC 6.12 comes with [[Libraries_released_with_GHC|a smaller set of libraries built in]] than 6.10.4 did, so for  those that are no longer shipped with ghc, we need to create binary packages in [extra]. That is, for (those in italics are already moved):
+
 
+
* ''[http://www.archlinux.org/packages/extra/x86_64/haskell-xhtml/  haskell-xhtml]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-regex-base/ haskell-regex-base]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-regex-compat/ haskell-regex-compat]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-regex-posix/ haskell-regex-posix]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-quickcheck/ haskell-quickcheck]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-parsec/ haskell-parsec]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-parallel/ haskell-parallel]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-packedstring/ haskell-packedstring]
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-network/ haskell-network]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-mtl/ haskell-mtl]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-hunit/ haskell-hunit]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-html/ haskell-html]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-haskell-src/ haskell-haskell-src]''
+
* ''[http://www.archlinux.org/packages/extra/i686/haskell-stm/ haskell-stm]''
+
 
+
== Additional [extra] packages ==
+
 
+
* haskell-deepseq
+
* haskell-extensible-exceptions
+
* haskell-terminfo
+
* haskell-dataenc
+
* haskell-hashed-storage
+
* haskell-mmap
+
 
+
== Update "provides" list for GHC ==
+
 
+
Done.
+
 
+
* The GHC package 'provides' list. It provides all the things [http://haskell.org/haskellwiki/Libraries_released_with_GHC listed here]
+
* The cabal2arch provides list to match.
+
 
+
cabal2arch '''assumes your pkgbuild tool can handle "provides"'''.''
+
 
+
== Update cabal2arch ==
+
 
+
Once cabal2arch has the new provides list, then new PKGBUILDs need to be generated with those new dependencies listed.
+
 
+
== The ./gen-index script ==
+
 
+
Done:
+
''The haddock index generation script used in all install hooks for Haskell libraries is in a different place for 6.12. We need to update the GHC package to fix this.''
+
 
+
== General breakages ==
+
 
+
Other packages may in general be broken by GHC changes (not Arch-specific things). Those are updated as noticed.
+
 
+
== yaourt is obsolete! ==
+
 
+
And the big final thing, yaourt is obsolete. Tools that don't support 'provides' won't work.
+

Latest revision as of 21:33, 30 January 2011

This article has been removed, all information in it was outdated.