Mac OS X

From HaskellWiki
Revision as of 22:04, 21 August 2006 by Wolfgang Jeltsch (talk | contribs) (OSX moved to Mac OS X)

Jump to: navigation, search

GHC 6.4.1 on OSX 3.9 (Panther) for PowerPC (PPC)

Haskell requires a newer version of XCode than the one distributed with OSX 10.3 (Panther), this can be downloaded from the Apple website (you need to create an account first) http://developer.apple.com/tools/download/ This is a fairly hefty download but it is nessisary

Then go get the GHC binary for OSX here http://www.haskell.org/ghc/dist/6.4.1/MacOSX/GHC-6.4.1.pkg.zip

Unpack the zip file & install the binary

GHC should be able to compile .hs files without any trouble.


Other notes:

This should also work for Tiger (OSX 10.4) and on Intel chips, but I dnt have any way to verify this.

The errors I recieved when trying to compile with only the distributed verison of XCode were like this: /tmp/ghc18985.s:232:Unknown pseudo-op: .subsections_via_symbols