Talk:MonadPlus reform proposal

From HaskellWiki
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

This is a good proposal, I think. The standard libraries use MonadZero only in two places: functions guard and msum. msum should probably be accompanied by a reduction with morelse, which should then be called mchoice.

Parsec already has operators (<|>) and choice with fitting semantics. Simply calling morelse (<|>) and mchoice choice might be even more convenient.

--Udo Stenzel 11:42, 20 January 2006 (UTC)