Revision as of 20:46, 1 January 2011 by Jesin
is the only method of the
should be included in the hierarchy. Better to be exactly mathematically correct once and for all.
2 Pure vs. returnWhen combining
, perhaps we should call it
, or something else that is not
? It would defy convention, yes, but we would already be making changes that would require a Legacy module for backwards compatability, and it may reduce confusion over what the function actually does, because Haskell's
is nothing like "return" in other languages.