Talk:Pairs of identifiers
read and show
I think the names
show in the Prelude of Haskell98 aren't a good choice
because the functions can be considered as natural pair
but this isn't reflected by their names.
show sound like some I/O operations which they are not.
The choice for the Modula-3 libraries (
Fmt) seems to be more suitable.
I had a nice discussion the other day with someone about the right name for tree nodes and leaves. The constructors I'm using as a result are
Leaf. Anyone feel differently?
I think 'del' is more natural pair for 'add'.
-- Evgeny Tarasov